Forum de leno - memo & co

depôt d'url utiles et variées
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 tuto config cisco

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
leno



Nombre de messages : 1053
Date d'inscription : 19/07/2006

MessageSujet: tuto config cisco   Jeu 1 Mar - 9:41

Bon voila la façon dont nous avons reussia configurer les ciscos vec TFM, etape par etape, en essayant de ne rien oublier Smile


[Introduction]

Ce tuto concerne les switchs Cisco Catalyst 2950 avec l'IOS version 12.1, qui semble le dernier en date et le plus courrement rencontré. si vous tombez sur un cisco qu'a pas cet ios, faudra peut etre changer l'ios, mais ça je ne sais pas encore comment qu'on fait :]
le but de la manip est de configurer les 3 premiers ports de chaque cisco de sorte a ce qu'ils se comportent comme un seul reliant les deux ciscos, afin que les débits soient répartis entre les 3 ports, et ainsi obtenir une liaison 300Mb/s entre le gymnase et la D7


[Reset du switch]
(histoire de partir du meme point)

Démarrer le switch et attendre qu'il se stabilise (2 diodes SYST et STAT allumées), puis maintenir le bouton MODE 2secondes jusqu'à ce que les 4 diodes du bas restent allumées. Relacher alors le bouton MODE, les 4 diodes devraient rester allumées.

Pour reseter le switch, il suffit de tenir appuyé le bouton "mode" trouvé en façade pendant 10 secondes avant de le relacher. normalement, au bout de 10 secondes (après avoir clignoté pendant environ 8secondes), les 4 diodes a coté du bouton restent allumées, c'est à ce moment qu'il faut relacher.
le switch reboot alors, sans conf
le reboot peut prendre un certain temps, soyez sûr que la situtaion du switch ne bouge plus avant de passer a la suite


[Chargement de la conf'min']

"express setup": permettant ensuite de prendre la main sur le switch

Même bouton (mode), mais pour 3 secondes cette fois Smile
les 4 diodes devraient là aussi toutes s'allumer au bout de ces 3 escondes de maintiens

Une fois le bouton relaché, le switch passe en mode "express setup" et est maintenant accessible par l'interface web


[Configuration par l'interface web]

Le switch est maintenant accessible par ses ports ethernet. Pour cela, configurez votre pc en 10.0.0.2/24 et branchez vous sur le port 1 par exemple (cable droit).
Attendez genre 30secondes que la connexion s'initialise.

Pour accéder à l'interface web, entrez 10.0.0.1 dans la barre d'adresse de votre naviguateur.

NB: il est recommandé d'utiliser Internet Explorer meme si on est tous bien d'accords pour dire que c'est une grosse merde, tout bêtement pasque l'interface ouaibe made-in cisco semble pas trop aimer firefox :/

Attention! prendre soin de désactiver le proxy dans IE:
"Outils" > "Option Internet" > onglet "Connexion" > "Paramètres Réseaux"
cocher "détecter automatiquement" et décocher le proxy

on accede alors a une page web permettant de configurer les principaux elements du switch: ip, password, telnet...

par exemple, la NA se passant souvent en 192.168.1.x, on prendra 192.168.1.251 et 192.168.1.252 pour chacun des switchs, avec le masque 255.255.255.0 qui va bien. un password du genre "crezo" fera bien l'affaire, et on laisse vide Default Gateway.

eventuellement, remplir Hostname (plus facile pour distinguer les deux switchs apres, en mettant par exemple 251 pour l'un et 252 pour l'autre, ou tout autre nom farfelu issu de votre imagination debordante)

activer le telnet peut aussi etre une bonne idée, si vous souhaitez continuer la configuration du switch sans passer par le cable console. Toutefois prenez garde dans ce cas à ne pas reconfigurer le port à partir duquel vous configurez le switch, ça fait mauvais effet (plantage pour moi)


[Chargement de la configuration Trunk]

Maintenant que le switch est configuré un minimum on va pouvoir s'amuser à modifier les parametres des ports 1, 2 et 3.

pour prendre la main sur le switch, on utilisera l'hyperterminal de windows (Accessoires >> communications >> hyperterminal)
pour configurer par le port console, mettre 9600 bits/s, 8bits de données, pas de bit de parité, 1 bit d'arret et selectionner le port COM (1 ou 2 suivant celui que vous avez connecté)
ENTER devrait faire apparaître le prompt du switch "NomSwitch> "

Il est bon de savoir qu'un switch cisco a plusieurs "profondeurs" d'interface:
- Premier niveau : le prompt ressemble à "NomSwitch> ", peu d'options sont accessibles. on aua surtout la commande "enable" qui permet de passer au second niveau
- Second niveau : le prompt comporte un # "NomSwitch# ", et de nombreuses commandes sont accessibles. on aura notemment "show running-config
- Troisieme niveau : configuration du switch, on y accede en tappant "configure terminal", ce niveau permet de configurer les différentes interfaces du switch et plus si affinitées...

Le but du jeu ici est de charger ces lignes de commandes, en ayant prit soin de se mettre en mode "enable":

Citation :

configure terminal
port-channel load-balance dst-mac
interface Port-channel 1
switchport mode trunk
no ip address
duplex full
flowcontrol send off
exit

interface FastEthernet 0/1
switchport mode trunk
no ip address
duplex full
speed 100
channel-group 1 mode on
spanning-tree portfast trunk
exit

interface FastEthernet 0/2
switchport mode trunk
no ip address
duplex full
speed 100
channel-group 1 mode on
spanning-tree portfast trunk
exit

interface FastEthernet 0/3
switchport mode trunk
no ip address
duplex full
speed 100
channel-group 1 mode on
spanning-tree portfast trunk
exit

interface FastEthernet 0/4
no ip address
exit
interface FastEthernet 0/5
no ip address
exit
interface FastEthernet 0/6
no ip address
exit
interface FastEthernet 0/7
no ip address
exit
interface FastEthernet 0/8
no ip address
exit
interface FastEthernet 0/9
no ip address
exit
interface FastEthernet 0/10
no ip address
exit
interface FastEthernet 0/11
no ip address
exit
interface FastEthernet 0/12
no ip address
exit
interface FastEthernet 0/13
no ip address
exit
interface FastEthernet 0/14
no ip address
exit
interface FastEthernet 0/15
no ip address
exit
interface FastEthernet 0/16
no ip address
exit
interface FastEthernet 0/17
no ip address
exit
interface FastEthernet 0/18
no ip address
exit
interface FastEthernet 0/19
no ip address
exit
interface FastEthernet 0/20
no ip address
exit
interface FastEthernet 0/21
no ip address
exit
interface FastEthernet 0/22
no ip address
exit
interface FastEthernet 0/23
no ip address
exit
interface FastEthernet 0/24
no ip address
exit

exit

copy running-config startup-config

Pour rentrer ces commandes, deux methodes au choix: a la main, ou en utilisant le menu "Transfert" -> "Envoyer un fichier texte" (ht.jpg)
puis en selectionnant le fichier cisco.txt que vous trouverez ici

Attention cependant a bien etre en mode enable pour faire ça

Après, un petit "show running-config" devrait vous sortir une jolie configuration dans ce style: config_gymnase


[Conclusion]

Normalement c'est que c'est bon :]
Notons quand même qu'on reste sceptiques quand au comportement reel des switchs, au point de se demander si la conf fait reellement ce qu'on voudrait qu'elle fasse... oui, en gros, on n'est meme pas sur que tout ça serve à qqchose Very Happy
C'est ça qu'est bon Wink


[Liens Utiles]
J'ajouterais juste à ça quelques liens utiles (voire fortement recommandés même):

premier : Premiere pierre de l'édifice par l'ancêtre commun à tous les responsables reseaux, gronono Very Happy

deuxieme : Mini-tuto par val

troisieme : post de chaussette avec digressions divers et variées Smile

quatrieme : (ou bien "express-setup.pdf" ici ) tuto made in cisco (ça fera bosser votre anglais) sur l'express-setup d'un 2950

cinquieme : (ou bien "trunking.pdf" ici ) tuto made in cisco sur le trunking en cisco
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
leno



Nombre de messages : 1053
Date d'inscription : 19/07/2006

MessageSujet: Re: tuto config cisco   Jeu 31 Mai - 3:33

.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
 
tuto config cisco
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Ma station d'observation et mes vidéos
» [TUTO]Héberger et faire apparaître une image
» couture pour enfant : tuto
» asa cisco
» TuTo installation De Mod pour Mount And blade Warbant [ Extra Invasion ]

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum de leno - memo & co :: Forum de leno - memo & co-
Sauter vers: